"Could not contact node rabbit@[machine_name]" after upgrading to RabbitMQ 3.6.5

Thursday, October 13, 2016

This error kept me busy for almost two days, so i thought it would be best to describe the steps i took to fix it Make sure that the erlang cookie file (.erlang.cookie) is configured correctly in all places. i.e. %HOMEDRIVE%%HOMEPATH% and %SYSTEMROOT%. it should contain the same value in all places Open the RabbitMQ command prompt with Administrator privileges Remove the RabbitMQ service by using the command: rabbitmq-service remove  Navigate to %APPDATA%\RabbitMQ\db Delete everything (make sure you have a backup just in case) Go back to the command promp and install the service with the command:...
tags: ,
one comment