"Could not contact node rabbit@[machine_name]" after upgrading to RabbitMQ 3.6.5

October 13, 2016

tags: ,
one comment

This error kept me busy for almost two days, so i thought it would be best to describe the steps i took to fix it

  1. Make sure that the erlang cookie file (.erlang.cookie) is configured correctly in all places. i.e. %HOMEDRIVE%%HOMEPATH% and %SYSTEMROOT%. it should contain the same value in all places
  2. Open the RabbitMQ command prompt with Administrator privileges
  3. Remove the RabbitMQ service by using the command: rabbitmq-service remove 
  4. Navigate to %APPDATA%\RabbitMQ\db
  5. Delete everything (make sure you have a backup just in case)
  6. Go back to the command promp and install the service with the command: rabbitmq-service install
  7. Check that the node is connected by running the command: rabbitmqctl status
  8. Hope you’ll have a smoother upgrade process than mine
Add comment
facebook linkedin twitter email

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*

one comment

  1. EvgeniDecember 27, 2016 ב 14:50

    1. Sometimes this phenomena happen when workstation is inserted into domain after installation of RabbitMQ is completed.

    2. In case when RabbitMQ command prompt is not available from the Start menu, please open “C:\Program Files (x86)\RabbitMQ Server\rabbitmq_server-3.5.2\sbin” in the command line

    Reply